Get in touch
Back
Downtime

fast_Press - Hosting Manager and fast_Press - File Transfer Protocol are down

Started 1 May at 03:05am CEST, resolved 1 May at 03:10am CEST.

fast_Press - Hosting Manager fast_Press - File Transfer Protocol
Resolved

fast_Press - Hosting Manager recovered.

Posted 1 May at 03:10am CEST.
Updated

fast_Press - File Transfer Protocol recovered.

Posted 1 May at 03:09am CEST.
Created

fastPress - Hosting Manager and fastPress - File Transfer Protocol went down.

Posted 1 May at 03:05am CEST.